Secret Server Moving to .NET Framework 4.5.1

Root > Secret Server
Starting in version 8.5.000000, Secret Server will start using the .NET Framework 4.5.1 platform. Previous versions of Secret Server used .NET 3.5 SP1. This change will require customers to ensure that the .NET Framework 4.5.1 is installed on the server where Secret Server resides. Support for your server can be determined by consulting the .NET Framework System Requirements page from Microsoft.  

Secret Server is moving to the .NET Framework 4.5.1 for its development platform to support additional features, such as Subject-Alternative-Names for SQL Server AlwaysOn and the latest version of PowerShell support. Upgrading the version of PowerShell support will allow for more remote scripting capabilities. This will also allow for more rapid development of Secret Server by giving developers access to additional tooling and resources.

Before upgrading to the 8.5.000000 release, please read Considerations Before Upgrading

For upgrade instructions for single and clustered environment please see the following article:

Add Feedback